Due to the Holiday, we will have limited Help Desk support Wednesday (11/22/2017) to Friday (11/24/2017).
Relax. We're here to help.

EnquireLEADS Recommended System Requirements

Enquire Support -

To facilitate a good EnquireLEADS™ user experience, each user needs a computer with a mouse, keyboard and color monitor. In addition, the minimum workstation requirements are listed below:

 

Computer Operating System

  • Windows 2000 SP4
  • Windows XP SP2/3
  • Windows Vista SP1
  • Windows 7 & 8 32/64 bit

Computer Speed

  • 1GB RAM of more
  • Premium 4 Processor at 2Ghz or better

Screen Resolution

  • 1024 x 768 or above for improved user experience

Supported Browsers

While EnquireLEADS may run without major issues in older browser versions, we do not actively test functionality in them and do not fix bugs that may appear in them. 

  • Internet Explorer (IE) Version 11 or above
  • Chrome 25 and above
  • Firefox 3.0 and above
  • Safari 4 and above

Browser Configuration & Add-ons

  • JavaScript Enabled
  • Cookies Enabled
  • Screen Zoom at 100% or less

Exchange Versions Supported

EnquireLEADS™ can be used without integrating with Exchange. These versions are not required to run EnquireLEADS™. If you would like to integrate, the versions listed below are supported:

  • Exchange 2013
  • Exchange 2010
  • Exchange 2010 SP1
  • Exchange 2010 SP2

 

Have more questions? Submit a request

Comments